Elgato Sound Cards & Media Devices Driver Download

12/14/2021by admin
DriverDriverElgato Sound Cards & Media Devices Driver DownloadCards

Elgato Capture Card Driver

Elgato Game Capture 4K60 Pro - 4K 60fps capture card with ultra-low latency technology for recording PS4 Pro and Xbox One X gameplay, PCIe x4, Black 4.2 out of 5 stars 188 $279.99 $ 279. I owned 2 elgato capture cards. You need to return that piece of crap back to the retailer were you bought it from. Just google 'audio sync elgato' and you receive tons of hits. Seems to me that elgato admits they have audio sync issues by the looks of the solotions they provide on their website. So for the solution.

Elgato Sound Capture Driver Update

Hello,
I'm looking to fix an issue I've had with my audio from my capture card. I want to try and be as thorough with my questioning, so I may write a bit so I apologize in advance. It's a gradual audio delay. I stream normally for 8 hours and the delay seems to happen over time. It's perfect in the beginning hours. I use an Elgato HD60 Pro capture card. I've contacted elgato about this and they gave me a program to download and run. The results from it were that the device was running perfectly. So, as a test, I purchased an HD60 S and I got the same results. Delay with two different cards.
I use the video capture device source in OBS. I've used the options game capture HD60 Pro and elgato game capture HD under device to no success. Originally, I used 'Output desktop audio (waveout)' which would send the audio through my desktop so I and stream could hear. But after a while, I started using window capture and just capture the elgato software in full screen on another monitor. This method had no audio delay, but it had audio pocket noises like static which only could be solved by restarting the elgato software. This part isn't my concern, but I wanted to mention it anyway. So, for what I'm using now. I'm using 'capture audio only' for audio output mode and I set the device under advanced audio properties to 'monitor only' so I could hear it.
What I found out is interesting. Using this method, my stream hears the audio perfectly with no delay over a time of 8 hours, but I still do. So it went from both of us hearing the delay under the waveout option to none of us hearing it using monitor capture and now only me hearing it using monitor only. Why would this happen? Any ideas what the cause may be and how to fix it?
Log File:
https://obsproject.com/logs/hrH4WmfnYPuJ4Le9
Comments are closed.